setup.py

changeset 50
510d7ac14280
parent 39
e8f9608ad204
child 53
cd7cffb43bfd
--- a/setup.py	Thu Feb 16 09:22:13 2017 +0200
+++ b/setup.py	Thu Feb 16 09:23:20 2017 +0200
@@ -2,23 +2,26 @@
 
 from setuptools import setup
 
-# Read the long description from the readmefile
+# Read the long description from the readmef ile
 with open("readme.rst", "rb") as f:
     long_descr = f.read().decode("utf-8")
 
 # Run setup
-setup(name='atmospheric_lidar',
-      packages=['atmospheric_lidar', ],
-      version='0.1.0',
+setup(name='atmospheric_lidar_reader',
+      packages=['atmospheric_lidar', 'atmospheric_lidar.scripts'],
+      version='0.2.0',
       description='Classes for reading raw atmospheric lidar data.',
-      long_description = long_descr,
+      long_description=long_descr,
       author='Ioannis Binietoglou',
-      author_email='binietoglou@noa.gr',
+      author_email='ioannis@inoe.ro',
       install_requires=[
-        "numpy",
-        "matplotlib",
-        "sphinx",
-        "pytest"
-    ],
-     )
-
+          "numpy",
+          "matplotlib",
+          "sphinx",
+          "pytest",
+          "netcdf4",
+      ],
+      entry_points={
+          'console_scripts': ['licel2scc = atmospheric_lidar.scripts.licel2scc:main'],
+      },
+      )

mercurial