setup.py

changeset 37
7c76fdbdf1a3
parent 36
a281a26f4626
child 39
e8f9608ad204
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/setup.py	Mon Feb 22 17:03:44 2016 +0200
@@ -0,0 +1,24 @@
+#!/usr/bin/env python
+
+from setuptools import setup
+
+# Read the long description from the readmefile
+with open("README.md", "rb") as f:
+    long_descr = f.read().decode("utf-8")
+
+# Run setup
+setup(name='atmospheric_lidar',
+      packages=['atmospheric_lidar', ],
+      version='0.1.0',
+      description='Classes for reading raw atmospheric lidar data.',
+      long_description = long_descr,
+      author='Ioannis Binietoglou',
+      author_email='binietoglou@noa.gr',
+      install_requires=[
+        "numpy",
+        "matplotlib",
+        "sphinx",
+        "pytest"
+    ],
+     )
+

mercurial